I’d like to know why my reverb in my Rockerverb MKIII stopped working.
Mikko: This could be caused by a number of things but the first and most obvious thing to check would be the reverb valve (12AT7). If this doesn’t solve the issue then it will most probably be a bad contact with the reverb cables, a faulty reverb tank or reverb transformer. In any case I recommend getting in touch with your local Orange Dealer or taking it to a local repair shop to get it looked at.

I think the HT fuse went in my OR15? Power amp tubes are very fresh. Any other reason why this could happen?
Mikko: Have you confirmed that it is the HT fuse that has gone or is this simply an assumption because you’re not getting any sound from the amp? If you’ve tested the HT fuse with a multimeter but it looks fine to the eye it could just be a bad fuse. You could try replacing the fuse with the correct type. If the fuse looks charred it has definitely blown due to a more serious fault in the amp. You say your output valves are new but unfortunately that doesn’t mean they haven’t failed yet. You could try bypassing the preamp entirely by plugging your guitar into the FX return to see if you’re getting any sound. This can help you narrow down the fault – if you’re getting sound from the FX Return you have a fault in the preamp (eg. a bad valve).

Why are your tubes connected straight on to the board…? Pretty much going to burn out the board due to this. Why wouldn’t you house them in a chassis then wired them to the board? For $2500 you would hope to have an amp that didn’t have short cuts/ cost cuts.
Mikko: With proper PCB design, a good layout, appropriate creepage clearances, correct voltages and the use of high quality materials and components this is really not a problem. The chassis’ on our amplifier heads are also mounted on the bottom of the sleeve meaning that all the heat will rise out of the chassis rather than into it. We have also made and still make hand wired amps such as the ‘Custom Shop 50’ where all the valve sockets are chassis mount and hand wired.. Of course this is always the preferred method but not everyone can afford a hand wired amp.

I’ve got a 1977 OR80 Overdrive Head (not the combo). It warms up and plays but is on the quiet side. If it turn the volume up to 50% I can talk louder than it….  I put in new matched tubes 1 week before this started happening. Any ideas?
Mikko: The OR80 is a very loud amp so it definitely sounds like you’re experiencing some faults here! Considering the age of the amplifier the first things to know before spunking any more money on tubes: has it been to a tech for an inspection and has it had the electrolytic capacitors replaced? From what you’re describing it does sound like a valve related issue to me. Even though your output valves are new it doesn’t mean they haven’t gone already. There could be an underlying issue in the poweramp or could be that you just received a duff pair of valves. When were the preamp valves replaced? One of these could have failed or worn out. The vintage Orange Amps are notorious for chewing through power valves quicker as they’ve got very high plate and screen voltages and no standby switch to protect the amp from huge inrush currents. I would definitely recommend taking it to a reputable technician who can inspect it, do the required repairs, replace the filter caps (if not done already) and get it biased properly. I would also recommend getting a standby switch installed. It can be installed on the SLAVE OUT on the back so there’s no need to drill new holes to the chassis.

I have a 90’s Overdrive 120 half-stack. (Also an OR15 that I love!) How close to the originals are the 90’s amps? I know some of the chassis, etc are original but is there any way to tell specifics?
Mikko:
For the most part they look pretty close to the originals. The preamp design looks very similar and even the PCB layout is nearly the same as on the 70’s models. Some of the component values are different, for example the capacitor values in the tonestack of the reissues were taken from the Overdrive Series Two circuit. The transformers on the reissues are of course from a different manufacturer. Those 90’s (pre ‘97) reissues were built in the U.K by Matamp and sold by Gibson as they had licensed the Orange name. I have never seen one of these amps or any circuit diagrams for them so I’m afraid I can’t be much more specific than that.

If someone can answer my questions it is probably you: Which Solid State amps can I use without a load? I have an OB1, can I use it without speakers? I was also thinking of getting a Little Bass Thing or a Terror Bass reissue, and that would be a decisive factor. There’s always contradictory information from people on the internet and even from the sales people at Orange. Thanks for your time!
Mikko: You’re fine to use any of those solid state amps without a load. With modern solid state amplifiers this is rarely an issue. This definitely comes in handy for silent recording at home!

Does the original Rocker 30 share a preamp stage with any of the modern heads? I heard the R32 has a different schematic. And is that because of the fx loop? Thanks! Love my Rocker.
Mikko: The Rocker 30 and the Rocker 32 share a very similar preamp stage, they’re nearly identical apart for a couple of components. A little bit of brightness was added to the Rocker 32 clean channel as people thought the Rocker 30 clean channel sounded a bit too warm. There were other design concepts implemented that made these amps very different. Such as: The ‘Rocker 30’ runs the preamp heaters at 5vAC rather than the typical 6.3vAC. The mains transformer used had a spare 5v winding for a rectifier valve (not used in the R30) and this tap was used for the preamp valves.. Very cool stuff! Also the cathode biased EL34 output stage sounds and feels very different.

My JR terror is extremely noisy at high gain… even with a quality noise gate… what could be the issue? P.S… I love your products!
Mikko: The Jim Root Terror is a 4 gain stage amplifier, so it will always have some noise to it at extremely high gain settings. But if you’re experiencing an offensive amount of noise it is very possible that you have a bad/noisy valve in your amp. I would try swapping out the first and second preamp valve one at a time to see if that does the trick. Also make sure you’re using your noise gate in the FX Loop! If you’re using a lot of gain there will always be some noise coming from the preamp so putting your noise gate in front of the amp isn’t going to do very much.

I have a 70’s OR80R combo. Turning up the reverb also adds high frequencies.
Mikko: ‘It will just do that’ is the short answer to this question. Some of the older Orange Amps, especially the rarer models with add-ons such as reverb, master volume, slave outs etc. can be a bit weird with some design quirks to say the least. The OR80R is a very rare amp and there weren’t many made in the first place so it wouldn’t surprise me if the reverb was implemented in some strange way. That said, I have never seen one of these amps in person and there aren’t even any original schematic diagrams left as far as I’m aware. A regular chassis with some rudimentary modifications was used to build these amps so even that shows it was more of a limited and experimental model. It looks like a separate PCB was used for the reverb components and no reverb transformer was used.

Reverb is out on my Rockerverb MKII 100 How do I know if it’s the fuse or spring?
Mikko: If your amp is working but your reverb isn’t, it won’t be a fuse. It will most likely be a dead reverb valve. The Rockerverb MKII uses two 12AT7 (ECC81) valves for the Reverb (positions V6 & V11) and if one of these is dead you won’t get any reverb. If that doesn’t solve the problem then we could be looking at faulty reverb leads, tank or even a faulty reverb transformer. I would recommend taking this to a reputable technician and it should be a fairly quick and inexpensive fault to fix.

My OR15 will turn on but won’t produce any sound. Worked fine the day before this happened. Have checked all fuses and tubes. Took to local shop, but they aren’t a certified Orange dealer, so they couldn’t really do much investigation. Any suggestions? Or do I need to have it sent in?
Mikko: When you checked the fuses did you do it by visual inspection only or did you test them with a multimeter as well? If it was only a visual inspection there is a possibility that your HT Fuse is just faulty (the filament could’ve come loose). You should plug your guitar directly into the FX Return of your OR15, this will bypass the preamp entirely and put your signal straight into the power amp. If this works it could tell there is a fault in the preamp (eg. a bad valve). You could also have a bad contact in your FX Loop jack sockets on the back of your amp. If one of these contacts has dirt or corrosion and something is not making contact it will cut your signal entirely. The FX Loop is a fully valve buffered loop running in a series configuration meaning the signal still goes through the valve and the switching jacks when unplugged. You should definitely try cleaning the FX Loop jack sockets, a simple way is to apply some contact cleaner (if you’ve got some) on a jack plug and inserting it into both sockets a dozen times. This should clear out any dirt and you’ll quickly find out if it was that! If any of the above doesn’t work or help you should definitely take it to a local amp technician/repair shop. They should all be capable of repairing the amp with or without being Orange Certified. Alternatively if you live in the U.K you’re more than welcome to send the amp in for us for a repair. If this is something you’d consider you can email us on workshop@orangeamps.com.

Would my OR15 ever need a “tune up”? Also, how often do the tubes need changing? Thanks!!
Mikko:
Yes your OR15 will eventually need a tune up! Lucky for you these amps are very low maintenance and easy to keep running for years by yourself if you’re comfortable with the occasional valve change. I personally don’t really change my valves unless there is an issue or the amp is starting to sound dull but it is good practice to at least change the output valves every now and then. This really depends on how often you play: If you’re playing everyday and gigging every week you probably want to change them at least once a year. If you play at home once a week and play the occasional gig they’ll last you a lot longer. The OR15 uses 2x EL84 valves in a cathode biased configuration meaning you won’t need to get the bias adjusted when you replace them. You just need to purchase a matched pair of EL84’s (they must be matched) and install them in your amp. I recommend JJ’s as they seem to make one of the most reliable and good sounding EL84’s at the moment, they are widely available and won’t cost you a fortune.

Since this morning I have no more sound on my Orange Rocker 15, but yesterday I had sound. Have my tubes gotten out of service?
Mikko: Assuming the amp still powers on yes it is very likely that one of your valves has gone bad. But first I would check the HT Fuse, this might seem fine on a visual inspection but if tested with a multimeter it could just be a bad fuse with a loose filament. I would also try plugging the guitar straight into the FX Return on the back of the amp. This bypasses the preamp entirely and let’s you plug straight into the power amp so if you’re getting sound the fault must be in the preamp (eg. a bad valve). You should also try and clean the FX Loop jack sockets. The signal still passes through the switching jacks when disconnected so any issues here could cause it to cut out. Apply some contact cleaner (if you’ve got any) on a jack plug and plug it into both sockets a dozen times. This should clear out any dirt or corrosion and fix the problem. If none of the above works it is definitely time to take it to your local Orange Dealer or an amp repair technician.

Which valves should I put in my OTR120? Thanks!
Mikko: For this amp I would try to pick output valves that can handle the higher plate & screen voltages. If I wanted to stick with EL34’s I’d probably go with Svetlana Winged C’s. The KT77 would be an interesting option, they’re a direct drop in replacement but can take the higher screen voltages and I’ve heard them sound great in other amps. Valve choices largely depend on taste and budget but I would ask the dealer about EL34’s that can handle higher plate and screen voltages. For preamp valves I’d personally go with some nice NOS valves like Mullards for example. There aren’t many preamp valves in it (1 preamp valve and 1 phase inverter) so it won’t cost you much, and they’ll last you a lot longer so you won’t be swearing everytime you blow an output valve.

So my OR100 just seems like it loses its balls about 30 minutes into playing. Worn out tubes?
Mikko: This will most probably be old and worn out tubes. If you’ve had these in your amp for a while it’s probably time for a visit to the tech for an inspection, a revalve and a bias!

My RV50MK3 is making an angry kinda grumble/buzz, I’ve taken the back off and tapped all the tubes with a pencil but that didn’t make any noise, where do I go from here? Love your amps.
Mikko: Is this only affecting one of the channels or both of your channels? Is this affected at all by the controls and tone controls of your amp including the reverb? The input jack is on a switching jack so when you unplug it it mutes the preamp. Does it shut up when you unplug your instrument lead from the amp? If the answer is yes to all or some of those questions the fault is most probably in the preamp. If it’s on both channels and none of the controls do anything to it then it’s most probably a power amp issue. It does sound like a valve related problem to me so it might be time to contact your local Orange Dealer or an amp repair technician about a service, new output valves and a proper bias adjustment. If your amp is still under warranty then take it back to your dealer and they will take care of this for you.

What do you use to clean pots that make scratchy noise from dust???
Mikko: Contact cleaner lubricant. They come from many brands but it must be the lubricated type. And don’t use too much! If the pot is still scratchy and didn’t improve at all after the first application the pot might be worn out or you might have a bad preamp valve that is putting DC on the pot.

So I don’t currently own an Orange but I figured you guys could help me out… I recently got a 1969 Marshall Super Lead (my first amp ever) it was serviced right after I bought it, got a new set of power tubes (matched quad) and got it biased. Just yesterday I bought a cab for it (a 1960BV model from 2003), I also bought a THD Hot Plate 16ohm Attenuator so I can use it at home. The problem is my amp gets WAYYY TOO HOOOOT!! After using it for a little over an hour my whole house smelled like a mix of burnt wood, metal and wires, and that smell didn’t go away for like 5 hours after I turned off the amp. I use my attenuator close to the right knob on the front and I was using my amp with the volume all the way up on both channels. I was looking up some information online and apparently people have issues with their Super Leads when they attenuate it too much? Have you guys ever experienced anything like this? Could over attenuation be the cause of the heat and the smell?
Mikko: You are playing your 100W amp at full tilt, things are going to get hot! The amp doesn’t know it’s got an attenuator after it which is kinda the entire point of the attenuator. It lets the amp work at maximum power, cooking the valves and pulling loads of current through the mains transformer and power supply. The transformers are going to get hot, the valves are going to get shit hot and don’t forget about the attenuator which is there to dissipate the excess power into heat before reaching your speakers. Of course things can get a bit too mental and you might blow some valves or worse one of your transformers.. I’ve seen this before.

Traynor YBA1 late 60s. What mods would you do? 
Mikko: First I would make sure the death cap has been removed and a proper 3 prong cord has been installed. If I had to mod it I’d probably mod one of the channels into a plexi style thing as we’re not a million miles off.

Do you guys pack an electrical print with the Amps?
Mikko: If you’re talking about a schematic diagram no we don’t send these out with our amps. We do supply these to service technicians around the world upon request.

What’s a good way to get into amp building?
Mikko: ‘I love the smell of solder in the morning’. Let’s start with the obvious – you need to be very interested in AMPS.. if not obsessed! If schematics, wires, old dusty valves and capacitors remind you of some kind of robotic pornography you might have what it takes! I knew for years that I wanted to build valve amps and work with vintage audio equipment but I just had no idea how to get into it. It was very frustrating because I was completely alone and I didn’t know anyone else who was interested in it so I didn’t have anyone to discuss the topic with. So the hardest thing is to find the information and resources to get started learning and initially you’ll have to do this all by yourself. Be prepared to spend many lonely nights in front of the computer with a cheap bottle of wine building amps in your imagination. The next most important thing is to get out there and meet other people who are into this stuff. That’s easier said than done as most techs are reclusive mad bastards but once you’ve made some friends who work in the industry you’ll be amazed at what you’ll start learning!

Your first project: Are you going to repair, restore/rebuild or scratch build an amp? I know you want to build amps but is this really the most sensible first project? Building amps from scratch costs a lot of money. It’s your first amp so you’re going to make some mistakes, buy some wrong parts etc. and there are no guarantees it will even work. So a more sensible first project could be a restoration. Yes vintage amps cost money too but if you choose wisely and do the work right you’ll at least make your money back or even turn a profit when you resell.. or end up with something really cool?! You will learn a lot more this way and after some success you will have the confidence to build your first amp. There are plenty of amazing books and resources out there, to name a few: The Tube Amp Book by Aspen Pitman, RCA Radio Designer’s Handbook by Langford Smith, Valve Wizard…

Did the overdrive 120‘s used different transformers thru the mid to end 70‘s?
Mikko: Yes Orange used a variety of different transformer manufacturers throughout the 70’s. I’ve seen Partridge in the very early ones, Parmeko towards the mid 70’s and the latest example from 1978 had Ladbroke transformers in it. 

Outside of broken input jacks, what is the most common failure for the amps you see?
Mikko: ‘User has been a twat’ or crap fuses seem to be the most common. You’d be surprised how many people put a pint in their amp!

Where is a good place to get replacement fuses for my Orange amp?
Mikko: If you’re in the U.K you should look on RS Components! They do free next day delivery so I get them from there. If you’re abroad you should try any other electronics/component supplier. The fuse size you’re looking for is 5x20mm and they’re really cheap.

Does the bell bottoms make the amp sounds better?
Mikko: They make everything better! Unless the flare’s too big and I can’t tell which pedal I’m treading on.

Where can I find bell bottoms as dope as these?
Mikko: The ladies section at ‘Council Thrift Shops’ in the corner of North Fairfax Avenue & Oakwood Avenue in Los Angeles, CA. Also there’s no changing room so you’ve got to strip on the shop floor. $8

What kind of oranges do you guys use to get those amps to sound so badass?
Mikko: The Orange Sunshine kind!

5 replies
  1. Pat Colucci
    Pat Colucci says:

    I have a 2019 rockerverb 100 mkiii (JJ power tubes)and 1 of the 12ax7 (pm tubes) went bad. If your were gonna replace all the preamp tubes what brand would you recommend and in what positions?
    Thanks

    Reply
  2. Zig Paul
    Zig Paul says:

    Instead of the proper 15vdc POSITIVE CENTER PIN power supply, I accidentally plugged an 18vdc NEGATIVE CENTER PIN power supply cable into my Mirco Dark in the home studio… It was just a split second and the power switch was in the OFF position, but something got cooked. Heard a little pop/noise and it smells a little like burnt electronics, but it still works – headphones, speaker out, the light, the effects loop, all knobs. Should I continue to worry? Should I have it checked out? Is there anything I can check (have the right tools and meters)?

    Reply
  3. Darrick Jones
    Darrick Jones says:

    I recently purchased an orange crush 35 rt. I have never taken it out of the house, it’s just a home Amp. This Amp has probably less than 30 hours on it and the overdrive quit working. I’m hoping it’s a fuse thing. I purchased it through Sweetwater but received no response. Maybe you can help me out??

    Reply
  4. Austin Barney
    Austin Barney says:

    Hi Mikko,

    I have an AD140 HTC which I purchased soon after Orange’s revival, maybe c. 2002. I’ve never had anything done to it, and it was sounding great until about a month ago, when sound ceased to come out of it. The light turns on, but not even a hum emits, so I’m thinking this is maybe a tube or wiring issue. Seeing as I am not an expert in either area, I’m assuming I should take this to an amp specialist or Orange dealer (not sure if there’s one in lower NY State where I live); would you agree, or is there something I should try at home first? Thanks, Austin

    Reply
  5. Greg
    Greg says:

    Hi. I’ve got early 1970s OR200 (quite rare because it’s Orange only branded, non-Matamp). I recently blew the HT fuse after pushing it hard. I’ve been told these amps are not good for pushing because of ultra-linear contruction, but swapping screen resistors to bigger value and bigger wattage would help. True?

    Reply

Leave a Reply

Want to join the discussion?
Feel free to contribute!

Leave a Reply

Your email address will not be published. Required fields are marked *